Welcome to Questions - Ask OpenNMS, where you can ask questions and receive answers from other members of the community.

How to configure OpenNMS to use Microsoft Exchange?

+1 vote
2,813 views

DEMONSTRATION Q/A

 

Please help me! My OpenNMS can't use Microsoft Exchange. If I use gmail, everything works fine.

OpenNMS version
asked Nov 29, 2013 by mfuhrmann (7,350 points)
Can you post your working gmail configuration ?

I used the one suggested in the wiki : (http://www.opennms.org/wiki/Gmail_example_javamail-configuration.properties), which is :
org.opennms.core.utils.useJMTA=false
org.opennms.core.utils.transport=smtp
org.opennms.core.utils.mailHost=smtp.gmail.com
org.opennms.core.utils.smtpport=587
org.opennms.core.utils.smtpssl.enable=false
org.opennms.core.utils.authenticate=true
org.opennms.core.utils.authenticateUser=foo@gmail.com
org.opennms.core.utils.authenticatePassword=pass4foo
org.opennms.core.utils.starttls.enable=true
org.opennms.core.utils.messageContentType=text/html
org.opennms.core.utils.charset=UTF-8

But it is not working : (notifd.log shows this result) :

2013-12-05 19:42:45,801 ERROR [Thread-278152] JavaMailer: Java Mailer messaging exception: javax.mail.MessagingException: Could not connect to SMTP host: smtp.gmail.com, port: 587;
  nested exception is:
        java.net.ConnectException: Connection timed out
javax.mail.MessagingException: Could not connect to SMTP host: smtp.gmail.com, port: 587;
  nested exception is:
        java.net.ConnectException: Connection timed out


Is it maybe a firewall issue ?


Regards
Hey amg,

this post was a demonstration for a guy from the discuss list. He asked how to configure OpenNMS to use MS Exchange. He told us, he was using the wiki config for gmail without any problems. So I configured my OpenNMS to use our Exchange server and posted the working configuration. Take a look: http://opennms.530661.n2.nabble.com/template/NamlServlet.jtp?macro=search_page&node=529575&query=%22How+to+Config+Mail+Notification%22&days=0

--
 Marcel

1 Answer

+2 votes
 
Best answer
Hey Marcel!

 

I'm using this configuration with Exchange 2008. And it works fine.

 

org.opennms.core.utils.fromAddress=EMAIL-ADDRESS

org.opennms.core.utils.mailHost=FQDN-MAILSERVER

org.opennms.core.utils.mailer=smtpsend

org.opennms.core.utils.transport=smtp

org.opennms.core.utils.smtpport=587

org.opennms.core.utils.smtpssl.enable=false

org.opennms.core.utils.useJMTA=false

org.opennms.core.utils.authenticate=true

org.opennms.core.utils.authenticateUser=EXCHANGE-USER

org.opennms.core.utils.authenticatePassword=EXCHANGE-PASSWORT

org.opennms.core.utils.starttls.enable=false

 

org.opennms.core.utils.messageContentType=text/html

org.opennms.core.utils.encoding=8-bit

org.opennms.core.utils.charset=utf8

org.opennms.core.utils.contentTransferEncoding=8-bit
answered Nov 29, 2013 by anonymous
selected Nov 29, 2013 by mfuhrmann
...