Welcome to Questions - Ask OpenNMS, where you can ask questions and receive answers from other members of the community.

How to configure multiple poller packages?

0 votes
1,774 views
I'm trying to build 2 poller packages with different polling cycles. Every package contains the snmp service. And every node is member of the corresponding surveillance category and has a corresponding detector.
Unfortunately all services in package '5min' don't work. Web UI tells me: "Not Monitored". What's wrong?
 
Here a simplified configuration (other services excluded):
 
 
<package name="5min">
        <filter>categoryname == 'poll-5min'</filter>
        <include-range begin="1.1.1.1" end="254.254.254.254"/>
        <include-range begin="::1" end="ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff"/>
        <rrd step="300">
            <rra>RRA:AVERAGE:0.5:1:2016</rra>
            <rra>RRA:AVERAGE:0.5:12:1488</rra>
            <rra>RRA:AVERAGE:0.5:288:366</rra>
            <rra>RRA:MAX:0.5:288:366</rra>
            <rra>RRA:MIN:0.5:288:366</rra>
        </rrd>
        <service name="SNMP" interval="300000" user-defined="false" status="on">
            <parameter key="oid" value=".1.3.6.1.2.1.1.2.0"/>
        </service>
        <downtime begin="0" end="300000" interval="30000"/>
        <downtime begin="300000" end="43200000" interval="300000"/>
        <downtime begin="43200000" end="432000000" interval="600000"/>
        <downtime begin="432000000" delete="true"/>
    </package>
 
 
<package name="1min">
        <filter>categoryname == 'poll-60sec'</filter>
        <include-range begin="1.1.1.1" end="254.254.254.254"/>
        <include-range begin="::1" end="ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff"/>
        <rrd step="60">
            <rra>RRA:AVERAGE:0.5:1:10080</rra>
            <rra>RRA:AVERAGE:0.5:12:7440</rra>
            <rra>RRA:AVERAGE:0.5:288:1830</rra>
            <rra>RRA:MAX:0.5:288:1830</rra>
            <rra>RRA:MIN:0.5:288:1830</rra>
        </rrd>
        <service name="SNMP" interval="60000" user-defined="false" status="on">
            <parameter key="oid" value=".1.3.6.1.2.1.1.2.0"/>
        </service>
        <downtime begin="0" end="60000" interval="30000"/>
        <downtime begin="300000" end="43200000" interval="300000"/>
        <downtime begin="43200000" end="432000000" interval="600000"/>
        <downtime begin="432000000" delete="true"/>
    </package>
 
<monitor service="SNMP" class-name="org.opennms.netmgt.poller.monitors.SnmpMonitor"/>
 
OpenNMS version
1.12.5
Operating system
CentOS 6.5 x64
PostgreSQL version
8.4.20
asked Mar 24, 2014 by mfuhrmann (7,350 points)
edited Mar 25, 2014 by mfuhrmann

2 Answers

0 votes
 
Best answer

The "Not monitored" means there is no matching poller package for your filter and include-range.

<filter>categoryname == 'poll-60sec'</filter>
<include-range begin="1.1.1.1" end="254.254.254.254"/>
<include-range begin="::1" end="ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff"/>

and

<filter>categoryname == 'poll-5min'</filter>
<include-range begin="1.1.1.1" end="254.254.254.254"/>
<include-range begin="::1" end="ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff"/>

you can try to verify the <filter> by using it in the notification if your problematic node is selected. Go to

Admin -> Configure Notifications -> Configure Event Notifications -> Just pick one and "Edit" -> Just go "Next" -> Try your filter "categoryname == 'poll-5min'" here and use "Validate rule results" to see if your problematic node is selected.

answered Mar 27, 2014 by indigo (10,110 points)
selected Mar 27, 2014 by mfuhrmann
Another typo... "poll-5mins" and "poll-5min". Also the collectd config was missing. There was just the default example1 package. I added a "poll-60sec" and "poll-5min" package with the required services and now it seems to work.
+1 vote
Will probably need more configuration.  These two packages overlap, so behavior is going to be strange.

I would verify that your device is responding to the OID you are trying to collect (for the monitor condition), and also go off some of these examples for a simple test case. http://www.opennms.org/wiki/SNMP_Monitor#Custom_Example:_Users_Logged_In

The 1min RRAs will need to be corrected to match 1m.. so 60 for a step and the rest matching to make sene of that period.
answered Mar 25, 2014 by Ken Eshelby (2,280 points)
I didn't see the copy+paste mistakes... Corrected in package 1min the rrd step from 300 to 60. And the intervals from 300000 to 60000. But it's still not working.
...