Welcome to Questions - Ask OpenNMS, where you can ask questions and receive answers from other members of the community.

Server chose SSLv3, but that protocol version is not enabled or not supported by the client

0 votes
1 view

Provisiond.log file contains blow error messages
WARN  [scanExecutor-8] o.a.c.p.PhaseInterceptorChain: Interceptor for {http://cxf.wsman.core.opennms.org/}IdentifyOperationsService#{http://cxf.
wsman.core.opennms.org/}Identify has thrown exception, unwinding now
org.apache.cxf.binding.soap.SoapFault: Error writing to XMLStreamWriter.
        at org.apache.cxf.binding.soap.interceptor.SoapOutInterceptor$SoapOutEndingInterceptor.handleMessage(SoapOutInterceptor.java:312) ~[cxf-rt-bindings-soap-3.1.5.jar:3.1.5]
        at org.apache.cxf.binding.soap.interceptor.SoapOutInterceptor$SoapOutEndingInterceptor.handleMessage(SoapOutInterceptor.java:289) ~[cxf-rt-bindings-soap-3.1.5.jar:3.1.5]
        at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:308) [cxf-core-3.1.5.jar:3.1.5]
        at org.apache.cxf.endpoint.ClientImpl.doInvoke(ClientImpl.java:514) [cxf-core-3.1.5.jar:3.1.5]
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:423) [cxf-core-3.1.5.jar:3.1.5]
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:324) [cxf-core-3.1.5.jar:3.1.5]
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:277) [cxf-core-3.1.5.jar:3.1.5]
        at org.apache.cxf.frontend.ClientProxy.invokeSync(ClientProxy.java:96) [cxf-rt-frontend-simple-3.1.5.jar:3.1.5]
        at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:139) [cxf-rt-frontend-jaxws-3.1.5.jar:3.1.5]
        at com.sun.proxy.$Proxy215.identify(Unknown Source) [?:?]
        at org.opennms.core.wsman.cxf.CXFWSManClient.identify(CXFWSManClient.java:152) [org.opennms.core.wsman.cxf-1.1.1.jar:?]
        at org.opennms.netmgt.provision.detector.wsman.WsManDetector.isServiceDetected(WsManDetector.java:96) [org.opennms.features.wsman-18.0.2.jar:?]
        at sun.reflect.GeneratedMethodAccessor881.invoke(Unknown Source) ~[?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_60]
        at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_60]
        at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:317) [org.apache.servicemix.bundles.spring-aop-4.0.5.RELEASE_1.jar:?]
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:201) [org.apache.servicemix.bundles.spring-aop-4.0.5.RELEASE_1.jar:?]
        at com.sun.proxy.$Proxy154.isServiceDetected(Unknown Source) [?:?]
        at org.opennms.netmgt.provision.service.IpInterfaceScan$2.run(IpInterfaceScan.java:192) [opennms-provisiond-18.0.2.jar:?]
        at org.opennms.core.tasks.SyncTask.run(SyncTask.java:93) [org.opennms.core.tasks-18.0.2.jar:?]
        at org.opennms.core.tasks.SyncTask$1.run(SyncTask.java:105) [org.opennms.core.tasks-18.0.2.jar:?]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_60]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_60]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_60]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_60]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_60]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_60]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:1.8.0_60]
Caused by: com.ctc.wstx.exc.WstxIOException: Server chose SSLv3, but that protocol version is not enabled or not supported by the client.
        at com.ctc.wstx.sw.BaseStreamWriter._finishDocument(BaseStreamWriter.java:1421) ~[woodstox-core-asl-4.4.1.jar:4.4.1]
        at com.ctc.wstx.sw.BaseStreamWriter.writeEndDocument(BaseStreamWriter.java:532) ~[woodstox-core-asl-4.4.1.jar:4.4.1]
        at org.apache.cxf.staxutils.DelegatingXMLStreamWriter.writeEndDocument(DelegatingXMLStreamWriter.java:119) ~[cxf-core-3.1.5.jar:3.1.5]
        at org.apache.cxf.binding.soap.interceptor.SoapOutInterceptor$SoapOutEndingInterceptor.handleMessage(SoapOutInterceptor.java:302) ~[cxf-rt-bindings-soap-3.1.5.jar:3.1.5]
        ... 31 more
Caused by: javax.net.ssl.SSLHandshakeException: Server chose SSLv3, but that protocol version is not enabled or not supported by the client.
        at sun.security.ssl.ClientHandshaker.serverHello(ClientHandshaker.java:452) ~[?:1.8.0_60]
        at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:206) ~[?:1.8.0_60]
        at sun.security.ssl.Handshaker.processLoop(Handshaker.java:979) ~[?:1.8.0_60]
        at sun.security.ssl.Handshaker.process_record(Handshaker.java:914) ~[?:1.8.0_60]
        at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062) ~[?:1.8.0_60]
        at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375) ~[?:1.8.0_60]
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403) ~[?:1.8.0_60]
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387) ~[?:1.8.0_60]
        at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559) ~[?:1.8.0_60]
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185) ~[?:1.8.0_60]
        at sun.net.www.protocol.http.HttpURLConnection.getOutputStream0(HttpURLConnection.java:1282) ~

OpenNMS version
asked Oct 9 by reddym (210 points)

Please log in or register to answer this question.

...